EarlyBird: εργαλείο ανίχνευσης ευαίσθητων δεδομένων

Το EarlyBird είναι ένα ς , ικανό να σαρώσει αποθετήρια πηγαίου για παραβιάσεις κωδικών πρόσβασης, PII, ξεπερασμένες μεθόδους κρυπτογράφησης, βασικά αρχεία και πολλά άλλα. Μπορεί να χρησιμοποιηθεί για σάρωση απομακρυσμένων αποθετηρίων git, τοπικών αρχείων ή καταλόγων ή ως βήμα προ-δέσμευσης.

Εγκατάσταση

Linux και Mac
[pastacode manual=”.%2Fbuild.sh%20%26%26%20.%2Finstall.sh” provider=”manual” lang=”php”/] Windows
[pastacode manual=”build.bat%20%26%26%20install.bat” provider=”manual” lang=”php”/]

Χρήση

Για να ξεκινήσετε μια βασική σάρωση EarlyBird σε ένα directory:
[pastacode manual=”%24%20go-earlybird%20–path%3D%2Fpath%2Fto%2Fdirectory%0D%0A” provider=”manual” lang=”php”/] [pastacode manual=”%24%20go-earlybird.exe%20–path%3DC%3A%5Cpath%5Cto%5Cdirectory%0D%0A” provider=”manual” lang=”php”/]
ή για σάρωση ενός απομακρυσμένου repo git:
[pastacode manual=”%24%20go-earlybird%20–git%3Dhttps%3A%2F%2Fgithub.com%2Famericanexpress%2Fearlybird%0D%0A” provider=”manual” lang=”php”/]

Documentation

 

Μπορείτε να κατεβάσετε το πρόγραμμα από εδώ.

iGuRu.gr The Best Technology Site in Greecefgns

κάθε δημοσίευση, άμεσα στο inbox σας

Προστεθείτε στους 2.085 εγγεγραμμένους.

Written by Anastasis Vasileiadis

Οι μεταφράσεις είναι σαν τις γυναίκες. Όταν είναι ωραίες δεν είναι πιστές και όταν είναι πιστές δεν είναι ωραίες.

Αφήστε μια απάντηση

Η ηλ. διεύθυνση σας δεν δημοσιεύεται. Τα υποχρεωτικά πεδία σημειώνονται με *

Το μήνυμα σας δεν θα δημοσιευτεί εάν:
1. Περιέχει υβριστικά, συκοφαντικά, ρατσιστικά, προσβλητικά ή ανάρμοστα σχόλια.
2. Προκαλεί βλάβη σε ανηλίκους.
3. Παρενοχλεί την ιδιωτική ζωή και τα ατομικά και κοινωνικά δικαιώματα άλλων χρηστών.
4. Διαφημίζει προϊόντα ή υπηρεσίες ή διαδικτυακούς τόπους .
5. Περιέχει προσωπικές πληροφορίες (διεύθυνση, τηλέφωνο κλπ).