Snap install σφάλμα: Cannot communicate with server

[prisna-google-website-translator]

Χτες το βράδυ προσπαθούσα να εγκαταστήσω την εφαρμογή Fluent Reader στην κύρια διανομή που χρησιμοποιώ (Debian).
Η εφαρμογή υπάρχει σαν snap, οπότε είπα να εγκαταστήσω το snapd με το Snap Store στο Debian, ούτως ώστε να προσθέσω την εφαρμογή Fluent Reader.

Όλα πήγαιναν μια χαρά στις 2 πρώτες εντολές:

sudo apt update
sudo apt install snapd

Η τρίτη εντολή sudo snap install core δυστυχώς παρουσίασε το παρακάτω σφάλμα:

Cannot communicate with server: Post http://localhost/v2/apps: dial unix /run/snapd.socket: connect: no such file or directory

Ας δούμε πως μπορούμε να το διορθώσουμε.

Αρχικά θα πρέπει να κάνουμε Unmask το snapd.service:

sudo systemctl unmask snapd.service

Μετά να το ενεργοποιήσουμε:

sudo systemctl enable snapd.service

και τέλος να τρέξουμε:

sudo systemctl start snapd.service

Αυτό ήταν. Το σφάλμα δεν εμφανίστηκε ξανά με την εντολή sudo snap install core και η εγκατάσταση της εφαρμογής Fluent Reader προχώρησε κανονικά με την παρακάτω εντολή:

sudo snap install fluent-reader --candidate

Ακολουθήσετε μας στο Google News iGuRu.gr at Google news

Written by giorgos

Ο Γιώργος ακόμα αναρωτιέται τι κάνει εδώ....

Αφήστε μια απάντηση

Η ηλ. διεύθυνση σας δεν δημοσιεύεται.

Το μήνυμα σας δεν θα δημοσιευτεί εάν:
1. Περιέχει υβριστικά, συκοφαντικά, ρατσιστικά, προσβλητικά ή ανάρμοστα σχόλια.
2. Προκαλεί βλάβη σε ανηλίκους.
3. Παρενοχλεί την ιδιωτική ζωή και τα ατομικά και κοινωνικά δικαιώματα άλλων χρηστών.
4. Διαφημίζει προϊόντα ή υπηρεσίες ή διαδικτυακούς τόπους .
5. Περιέχει προσωπικές πληροφορίες (διεύθυνση, τηλέφωνο κλπ).


  +  53  =  62